软件共享吧


360卫士
360浏览器
360杀毒
镇魔曲页游
QQ浏览器
联想管家
腾讯视频
加速浏览器
酷狗音乐

加速浏览器
爱奇艺
酷我音乐
爱奇艺PPS
快压
看图王
游戏盒子
91y游戏
小鱼便签
ABC看图
当前位置: 主页 > 行业软件 >

WordPress 5.2 “Jaco”提供更多开发者福利,对系统要求也更高

时间:2019-05-19 17:32来源:网络生活触角 作者:admin 点击:
WordPress的5.2Jaco版于5月7日正式发布,以纪念美国著名贝斯手Jaco Pastorius,该版本可在网站后台在备份好数据以后,直接更新即可。注意更新前请注意做好数据备份! WordPress后台更新提醒 WordPress 5.2除5.1版本已有的站点健康检查及提示功能、PHP错误保

WordPress的5.2“Jaco”版于5月7日正式发布,以纪念美国著名贝斯手Jaco Pastorius,该版本可在网站后台在备份好数据以后,直接更新即可。注意更新前请注意做好数据备份!

 

WordPress 5.2 “Jaco”提供更多开发者福利,对系统要求也更高

WordPress后台更新提醒

WordPress 5.2除5.1版本已有的站点健康检查及提示功能、PHP错误保护功能外,主要新增更新内容有:更加友好的程序升级功能;仪表盘全新的图标;WordPress插件适配PHP版本提醒功能和开发者福利。

WordPress 5.2 “Jaco”提供更多开发者福利,对系统要求也更高

WordPress仪表盘在线更新

(1)更加友好的程序升级功能

许多变化协同工作,以改善使用屏幕阅读器和其他辅助技术的人的上下文感知和键盘导航流程。

(2)全新的仪表盘图标新

十三个新图标,包括Instagram,BuddyPress的一套图标,以及用于全球整合的旋转地球图标。在仪表板中找到它们并享受一些乐趣!

(3)插件兼容性检查

WordPress现在将自动确定您的网站的PHP版本是否与已安装的插件兼容。如果插件需要比您的网站当前使用的更高版本的PHP,WordPress将不允许您激活它,以防止潜在的兼容性错误。

WordPress 5.2 “Jaco”提供更多开发者福利,对系统要求也更高

开发者福利

(4)PHP Version Bump

该版本支持的最低PHP版本现在为5.6.20。从WordPress 5.2 开始,主题和插件可以安全地利用命名空间,匿名函数等等!

(5)隐私更新

新的主题页面模板,条件函数和两个CSS类使得隐私策略页面的设计和自定义变得更加容易。

(6)New Body Hook

5.2引入了一个wp_body_open钩子,它允许主题支持在<body>元素的开头注入代码。

(7)构建JavaScript

通过在wordpress / scripts包中添加webpack和Babel配置,开发人员将不必担心设置复杂的构建工具来编写现代JavaScript。

WordPress 5.2 “Jaco”提供更多开发者福利,对系统要求也更高

WordPress 5.2版本更新完成

从WordPress 5.2版本开始,WordPress官方确认不在支持PHP 5.6.20以下版本。而且如果继续使用低版本的PHP,虽然可以继续运行PHP,但今后将不能在线更新使用最新版的WordPress程序。更新至WordPress 5.2版前,切记注意备份以防意外。更新后,将获得新版的开发者福利,享受更多开放自由。



微信扫一扫,关注该微信公众号:netcnspy 网络生活触角,了解更多内容吧!

 
(责任编辑:admin)
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容